facebook.com

This is where you should report issues arising from the subscription filters.

Moderator: EasyList Authors

Post Reply
ajnspencer
New Member
New Member
Posts: 1
Joined: Thu Mar 08, 2018 10:18 am
Reputation: 0

facebook.com

Post by ajnspencer » Thu Mar 08, 2018 10:46 am

Hi,

Lord knows removing stuff from Facebook is usually a pleasure, but I've noticed recently that EasyList is removing all page posts from my News Feed and Pages feed. This isn't ads or "page stories you may like" and that kind of nuisance but all content from pages I've asked to see.

The feed loads normally but then you can see them being plucked away by the Display:None Fairy with nary a 50p left in it's place. It's anything that not a friend status, links, videos, images, all are hidden.

It's definitely the EasyList filter doing it as I've tested switching bits of Adblock Plus off and on, and the only time it happens is when EasyList is active, either on it's own or with others. I've tried searching for differences in the individual feed stories to see if I can spot a common thread that would block A but leave B, but couldn't find anything myself.

I've got no personal filters yet (new PC) and both Adblock Plus and the filter are fully updated and the newest versions, on fully updated Chrome. Any ideas would be gratefully received as I'd rather not stop using EasyList and definitely don't want to whitelist Facebook...

Thanks!

xegara
New Member
New Member
Posts: 5
Joined: Mon Mar 19, 2018 5:04 am
Reputation: 0

Post by xegara » Mon Mar 19, 2018 5:10 am

Same issue here for a few weeks now using uBlock Origin. I can see articles loading in the feed, and they instantly get removed, causing loading of articles until they are all hidden.

I'm actually surprised that this has not been fixed yet, considering the amount of people using Facebook daily. This made me think that it might be a conflicting issue with another addon or another filter, though my troubleshooting in that regard has been unsuccessful.

intense
Contributor
Contributor
Posts: 8043
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 120

Post by intense » Mon Mar 19, 2018 7:09 am

Provide some info: uBo version, browser version, all the filter lists enabled in uBo (or other adblocker).

rhanajoy
AdBlock Community Manager
AdBlock Community Manager
Posts: 292
Joined: Fri Jul 03, 2015 10:40 am
Reputation: 2

Post by rhanajoy » Thu Mar 22, 2018 2:34 pm

We've been getting similar reports for a few weeks now. I kept thinking someone would report it. Our users tell us that it's not just posts in their news feed that are disappearing. They're using Chrome, but since other posters here are reporting the same issues with ABP and uBO, and one of our users is seeing the same thing in Vivaldi, this doesn't appear to be a browser- or ad blocker-specific issue. Our developer thinks there may be a problem with one or more hiding filters in EasyList.

Here are three reports:
Facebook has implemented a tagging method on their comment boxes. This applies to posts from news sources. You will see a line of @name with the comment box. With Adblock enabled, when you click in the comment box the entire post disappears in no more than 2 seconds. With Adblock disabled, the posts do not disappear. I have spent approximately 3 days debugging this action by disabling one by one any and all extensions and finally zeroed in on Adblock being the problem.
1.Open Facebook News feed
2.Open comments of a post or a video
3.The post is hidden
few weeks ago Facebook started to act very weird and I've found AdBlock is causing these issues.

What is happening:
1) some posts disappear while scrolling through News Feed, it seems its mostly random, I can see them for a second or so, then they are gone
2) if I try to see comments below post displayed on News Feed, that post disappears immediatly everytime
3) same happens when I try to like or react to the post - it disappears after clicking like button
4) all of these happen only on News Feed, if I open some FB page (e.g. 9GAG) and find very same post everything is okay
5) if I turn AdBlock off and then refresh there are no issues, when I turn AdBlock on and refresh again issues come back (observed for longer time).

This might be a hint - first time I noticed issues about time when Facebook shuted down Explore Feed, which they were testing in few countries. I thought problems with post are just some minor issue until they fully revert from Explore Feed back to News Feed, but it is actually AdBlock thing. Maybe they implemented some code that is preventing AdBlock to work properly. I tried on Chrome and Vivaldi browser - happens on both.
Rhana
AdBlock Community Manager

Posting on behalf of AdBlock (not ABP), when users come to us first and we have some reason to get involved with the discussion. http://help.getadblock.com

intense
Contributor
Contributor
Posts: 8043
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 120

Post by intense » Thu Mar 22, 2018 3:06 pm

@rhanajoy You should ask your users to watch the logger and report what hiding filters are triggered.

I cannot reproduce the issue in uBo/ ABP.

The sponsored articles could quickly flash and then disappear but this is expected.

rhanajoy
AdBlock Community Manager
AdBlock Community Manager
Posts: 292
Joined: Fri Jul 03, 2015 10:40 am
Reputation: 2

Post by rhanajoy » Thu Mar 22, 2018 7:17 pm

Yup, that should happen for sponsored and suggested posts, but not for comments and normal posts. I'll ask our more technically-minded users to try that and report what they see. If they get back to me, I'll post their results here. Thanks!
Rhana
AdBlock Community Manager

Posting on behalf of AdBlock (not ABP), when users come to us first and we have some reason to get involved with the discussion. http://help.getadblock.com

intense
Contributor
Contributor
Posts: 8043
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 120

Post by intense » Sat Mar 24, 2018 3:32 pm

Who has the issue in this thread could test these filters

Code: Select all

facebook.com#@?#div[id^="hyperfeed_story_id_"]:-abp-has(input[data-next-question-id])
facebook.com#@?#div[id^="hyperfeed_story_id_"]:-abp-has(a[href="#"]:-abp-contains(Char))
facebook.com#@?#div[id^="hyperfeed_story_id_"]:-abp-has(a[href="#"]:-abp-contains(Sp))
facebook.com#@?#div[id^="hyperfeed_story_id_"]:-abp-has(a[href="#"]:-abp-contains(Spon))

xegara
New Member
New Member
Posts: 5
Joined: Mon Mar 19, 2018 5:04 am
Reputation: 0

Post by xegara » Sun Mar 25, 2018 10:19 am

That works as a temporary workaround.

intense
Contributor
Contributor
Posts: 8043
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 120

Post by intense » Sun Mar 25, 2018 11:52 am

added in uBo, waiting for easylist authors
https://github.com/uBlockOrigin/uAssets ... 82ce7954f4

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 13785
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 141
Location: EasyList Forum

Post by smed79 » Wed Mar 28, 2018 12:50 am

•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use imgur.com, imgbb.com or vgy.me to upload your screenshots

stobber
New Member
New Member
Posts: 1
Joined: Tue Apr 17, 2018 6:09 am
Reputation: 0

Post by stobber » Tue Apr 17, 2018 6:12 am

static filter rule

Code: Select all

||facebook.com/xti.php?
blocks Facebook's news feed.
 ! Message from: Lanik
Merged rules#forumsearch

intense
Contributor
Contributor
Posts: 8043
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 120

Post by intense » Tue Apr 17, 2018 6:28 am

No issues on FB for me.

User avatar
fanboy
EasyList Author
EasyList Author
Posts: 9929
Joined: Wed Sep 05, 2007 8:17 pm
Reputation: 20

Post by fanboy » Tue Apr 17, 2018 8:03 am

Not aware of any issues with fb atm?

amoisidis
New Member
New Member
Posts: 1
Joined: Wed Apr 25, 2018 10:49 am
Reputation: 0

Post by amoisidis » Wed Apr 25, 2018 10:53 am

Hi you guys,

Awesome tool. It’s wonderful. Unfortunately, it does not solve the problem completely. Zuckerberg and his gang of [censored] cannot block the account anymore, now they disable the account. Is there anyway to block this action of inactivation of account?

Many thanks
Tony
 ! Message from: Lanik
Merged rules#forumsearch
 ! Message from: smed79
Be respectful rules#attack

Reporter
Senior Member
Senior Member
Posts: 66
Joined: Sun Jun 07, 2009 5:22 am
Reputation: 0

Post by Reporter » Fri May 18, 2018 1:54 pm

Go to any Facebook group.
Comment any post by uploading a gif image or some image.
The image appears to be uploaded successfully, but will fail when you press enter.

Note: Your account have to be on the new comment interface. The comment is in a grey speech bubble.
 ! Message from: Lanik
Merged rules#forumsearch

intense
Contributor
Contributor
Posts: 8043
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 120

Post by intense » Fri May 18, 2018 2:49 pm

Open your adblocker's logger and see what filters are triggered while uploading the gif file

rhanajoy
AdBlock Community Manager
AdBlock Community Manager
Posts: 292
Joined: Fri Jul 03, 2015 10:40 am
Reputation: 2

Post by rhanajoy » Fri Aug 17, 2018 6:08 am

This is still happening. @intense, one of our users found that the following filters are triggered on Facebook’s wall:

Code: Select all

facebook.com#?#div[id^="hyperfeed_story_id_"]:-abp-has(a[href*="is_sponsored"])
facebook.com#?#div[id^="hyperfeed_story_id_"]:-abp-has(div[id^="feed_subtitle_"] > span > a[class*="_"][href="#"] > div)
Adding those filters to the disabled filters solves the problem.
Rhana
AdBlock Community Manager

Posting on behalf of AdBlock (not ABP), when users come to us first and we have some reason to get involved with the discussion. http://help.getadblock.com

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 13785
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 141
Location: EasyList Forum

Post by smed79 » Fri Aug 17, 2018 6:22 am

rhanajoy wrote:Adding those filters to the disabled filters solves the problem.
Why don't you disable them in your list https://cdn.adblockcdn.com/filters/adblock_custom.txt ?
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use imgur.com, imgbb.com or vgy.me to upload your screenshots

intense
Contributor
Contributor
Posts: 8043
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 120

Post by intense » Fri Aug 17, 2018 6:29 am

@rhanajoy if you are talking about the uploading issue, no problem here: tested in ABP / uBo / chrome.

rhanajoy
AdBlock Community Manager
AdBlock Community Manager
Posts: 292
Joined: Fri Jul 03, 2015 10:40 am
Reputation: 2

Post by rhanajoy » Fri Aug 17, 2018 5:56 pm

@smed79 We could, but then the sponsored posts aren't blocked. Catch-22.

@intense This issue: viewtopic.php?p=134216#p134216
Rhana
AdBlock Community Manager

Posting on behalf of AdBlock (not ABP), when users come to us first and we have some reason to get involved with the discussion. http://help.getadblock.com

intense
Contributor
Contributor
Posts: 8043
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 120

Post by intense » Fri Aug 17, 2018 6:04 pm

Well, I cannot reproduce the issue.

However, if a user can reproduce it, he should save the page (folder + html), zip them, upload on some server and post here the link (or send it to you ...and you post here)

rhanajoy
AdBlock Community Manager
AdBlock Community Manager
Posts: 292
Joined: Fri Jul 03, 2015 10:40 am
Reputation: 2

Post by rhanajoy » Mon Aug 20, 2018 4:03 pm

I'll ask him to do that. Thanks!
Rhana
AdBlock Community Manager

Posting on behalf of AdBlock (not ABP), when users come to us first and we have some reason to get involved with the discussion. http://help.getadblock.com

Reporter
Senior Member
Senior Member
Posts: 66
Joined: Sun Jun 07, 2009 5:22 am
Reputation: 0

Post by Reporter » Sun Sep 09, 2018 9:27 am

The sponsored ads and the ads in the sidebar appear again. I tried the above filters but are not working.

intense
Contributor
Contributor
Posts: 8043
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 120

Post by intense » Sun Sep 09, 2018 9:41 am

@Reporter

- what adblocker are you using ?
- try these filters

Code: Select all

facebook.com#?#[id^=hyperfeed_story_id_]:-abp-has(a[href*="client_token"])
facebook.com#?#[id^=hyperfeed_story_id_]:-abp-has(a[href*="utm_campaign"])
facebook.com#?##substream_1:-abp-has([id^="feed_subtitle_"]:-abp-contains(Sp))
- if still does not work see the instructions
viewtopic.php?p=139811#p139811

Reporter
Senior Member
Senior Member
Posts: 66
Joined: Sun Jun 07, 2009 5:22 am
Reputation: 0

Post by Reporter » Mon Sep 10, 2018 1:02 am

For some weird reasons, the filters don't get any hit but the sponsored ads and the ads in the sidebar are suddenly gone.
I use Easylist and EasyPrivacy.
I'm using non-English language interface in Facebook.
I'll see if the problem re-appears.

Zambfd
New Member
New Member
Posts: 1
Joined: Mon Sep 17, 2018 12:00 pm
Reputation: 0

Post by Zambfd » Mon Sep 17, 2018 12:01 pm

Code: Select all

facebook.com#?#div[id^="hyperfeed_story_id_"]:-abp-has(a[href*="utm_campaign"])
Das sorgt dafür, dass auch normale Beiträge im User-Stream verschwinden. Mit dem Tag möchte man als Seitenbetreiber nur gern nachvollziehen, welche Social-Media-Portale für den eigenen Content funktionieren. Da steckt keine Werbung drin.

ebxpm
New Member
New Member
Posts: 1
Joined: Wed Sep 19, 2018 3:18 pm
Reputation: 0

Post by ebxpm » Wed Sep 19, 2018 3:31 pm

Code: Select all

facebook.com#?#div[id^="hyperfeed_story_id_"]:-abp-has(a[href*="utm_campaign"])
This addition seems to be blocking all normal, non-ad posts from publishers like the Telegraph and the Independent. They use the utm_campaign as a way to track performance over different fb-pages, etc. Has nothing to do with adds so I'm not sure why it's being blocked.

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 13785
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 141
Location: EasyList Forum

Post by smed79 » Sat Sep 22, 2018 1:15 pm

•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use imgur.com, imgbb.com or vgy.me to upload your screenshots

Post Reply