NSFW xvideos.com

This is where you should report issues arising from the subscription filters.

Moderator: EasyList Authors

yoyo94
Site Member
Site Member
Posts: 10
Joined: Fri Aug 19, 2016 5:35 pm
Reputation: 0

NSFW xvideos.com

Post by yoyo94 » Mon Jan 30, 2017 2:43 pm

Hi !

A new video URL seems to be blocked by EasyList

Code: Select all

https://xvideos-im-8d00ad00-7296588-hls.s.loris.llnwd.net/1485798018/110/cc55cd5e901a4c8d93bec44f47cb79b9/videos/hls/34/ff/b6/34ffb64425f77bd9ebdba3623bf012c8/hls.m3u8
www.xvideos.com
XMLHTTPREQUEST
|https://$script,third-party,xmlhttprequest,domain=xvideos.com

EasyList

Allowing *.llnwd.net domain seems to be the solution

yoyo94
Site Member
Site Member
Posts: 10
Joined: Fri Aug 19, 2016 5:35 pm
Reputation: 0

Post by yoyo94 » Tue Feb 21, 2017 11:10 am

Hi !

Do you have an update for that ?

On AdBlock, the chat is not working even when xvideos.com is whitelisted

Code: Select all

https://upload.xvideos.com/account/chat
AdBlock extension need to be completly removed to allow chat to work
 ! Message from: smed79
Removed your link links

intense
Contributor
Contributor
Posts: 7700
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 109

Post by intense » Sat Apr 29, 2017 3:31 pm

provide a test account or
submit an issue report (firefox + ABP) and then post here the report link

User avatar
fanboy
EasyList Author
EasyList Author
Posts: 9901
Joined: Wed Sep 05, 2007 8:17 pm
Reputation: 20

Post by fanboy » Sun Apr 30, 2017 6:10 am

Code: Select all

[email protected]:~/git/easylist/easylist_adult$ grep llnwd *
adult_specific_block.txt:@@||llnwd.net^$third-party,xmlhttprequest,domain=xvideos.com
Already whitelisted.

KittKat669
New Member
New Member
Posts: 2
Joined: Sun Jun 04, 2017 5:03 am
Reputation: 0

Post by KittKat669 » Mon Jun 05, 2017 3:24 am

I'm having this same problem on my cellphone. It'll connect but it won't load messages. I'm not using an ad blocker of any kind

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 13159
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 128
Location: EasyList Forum

Post by smed79 » Mon Jun 05, 2017 3:53 am

KittKat669 wrote:
Mon Jun 05, 2017 3:24 am
I'm not using an ad blocker of any kind
What is the report between your problem and easylist ?

:roll:
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use vgy.me, imgur.com or cubeupload.com to upload your screenshots

yoyo94
Site Member
Site Member
Posts: 10
Joined: Fri Aug 19, 2016 5:35 pm
Reputation: 0

Post by yoyo94 » Fri Oct 06, 2017 2:42 pm

Hi

A new URL format is blocked

Code: Select all

https://vid-egc.xvideos-cdn.com/videos/hls/7e/8c/2b/7e8c2b1006823c94c080712726af3f20/hls.m3u8?RPHA8S_V4IRAtkBqPAE4caVZmLpOMp3PidRFwSWPk8MOWN4StgZAGN28AA1zTQqOMpg4xeCg6Dg9sd_P0BANArOXcmNn3j5OgIOkI4hhJeToQJLt5aNPNZIN7fMzR0XFbJgF3k8K7C0V2GIaaVbg91gi9Q
www.xvideos.com
XMLHTTPREQUEST
|https://$script,third-party,xmlhttprequest,domain=xvideos.com
EasyList
*.xvideos-cdn.com need to be allowed for XMLHTTPREQUEST

xvideos-tech
New Member
New Member
Posts: 6
Joined: Tue Sep 06, 2016 11:45 am
Reputation: 0

Post by xvideos-tech » Wed Oct 11, 2017 8:01 pm

Hey guys !

Any update on the last report ?

All *.xvideos-cdn.com should be allowed. They are legitimate urls.

Regards

SSV
New Member
New Member
Posts: 1
Joined: Fri Oct 13, 2017 9:55 am
Reputation: 0

Post by SSV » Fri Oct 13, 2017 10:06 am

Would we be able to get an update as to when this could be whitelisted, thanks
yoyo94 wrote:
Fri Oct 06, 2017 2:42 pm
Hi

A new URL format is blocked

Code: Select all

https://vid-egc.xvideos-cdn.com/videos/hls/7e/8c/2b/7e8c2b1006823c94c080712726af3f20/hls.m3u8?RPHA8S_V4IRAtkBqPAE4caVZmLpOMp3PidRFwSWPk8MOWN4StgZAGN28AA1zTQqOMpg4xeCg6Dg9sd_P0BANArOXcmNn3j5OgIOkI4hhJeToQJLt5aNPNZIN7fMzR0XFbJgF3k8K7C0V2GIaaVbg91gi9Q
www.xvideos.com
XMLHTTPREQUEST
|https://$script,third-party,xmlhttprequest,domain=xvideos.com
EasyList
*.xvideos-cdn.com need to be allowed for XMLHTTPREQUEST

yoyo94
Site Member
Site Member
Posts: 10
Joined: Fri Aug 19, 2016 5:35 pm
Reputation: 0

Post by yoyo94 » Tue Nov 07, 2017 2:40 pm

Hi again !

I report the issue with the domains *.xvideos-cdn.com more than 1 month ago.

Video url path like :

Code: Select all

https://vid-egc.xvideos-cdn.com/videos/hls/7e/8c/2b/7e8c2b1006823c94c080712726af3f20/hls.m3u8?RPHA8S_V4IRAtkBqPAE4caVZmLpOMp3PidRFwSWPk8MOWN4StgZAGN28AA1zTQqOMpg4xeCg6Dg9sd_P0BANArOXcmNn3j5OgIOkI4hhJeToQJLt5aNPNZIN7fMzR0XFbJgF3k8K7C0V2GIaaVbg91gi9Q
are blocked by adblock plus causing video playback error.

Theses URLs are not ad related, it's normal video HLS path, and should not been blocked

Thanks

yoyo94
Site Member
Site Member
Posts: 10
Joined: Fri Aug 19, 2016 5:35 pm
Reputation: 0

Post by yoyo94 » Tue Nov 14, 2017 2:41 pm

Hi !

Do you have any news about this issue ?

pronlover
New Member
New Member
Posts: 1
Joined: Thu Nov 16, 2017 9:16 am
Reputation: 0

Post by pronlover » Thu Nov 16, 2017 9:22 am

Hi all. this has been an issue for some time now. Is anyone looking into this issue?
Please review/update the block lists for xvideos.com

intense
Contributor
Contributor
Posts: 7700
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 109

Post by intense » Thu Nov 16, 2017 9:53 am

This restrictive filter |https://$script,third-party,xmlhttprequest,domain=xvideos.com (I guess) was added due to your popups / popunders / redirects, so don't wonder you (I mean webmasters) have now issues with the normal stuff.

Clean up your site and probably the easylist authors will examine again your site.

yoyo94
Site Member
Site Member
Posts: 10
Joined: Fri Aug 19, 2016 5:35 pm
Reputation: 0

Post by yoyo94 » Thu Nov 16, 2017 1:13 pm

intense wrote:
Thu Nov 16, 2017 9:53 am
This restrictive filter |https://$script,third-party,xmlhttprequest,domain=xvideos.com (I guess) was added due to your popups / popunders / redirects, so don't wonder you (I mean webmasters) have now issues with the normal stuff.

Clean up your site and probably the easylist authors will examine again your site.
The rule you are speaking about is to block ads primarly, fine.

But we are currently changing our site architecture, and we are using a separate domain for video delivery (*.xvideos-cdn.com instead of *.xvideos.com)
To play video on user end, we are using Hls.js library that make XmlHttpRequest to download video files.

And AdBlock is blocking theses request.

You already add an exception for llnw before. The only thing we ask for is to add an exception for *.xvideos-cdn.com

Thanks

Ps: We have stopped trying to bypass adblock since a long time ago. This request is not to display some ads.

intense
Contributor
Contributor
Posts: 7700
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 109

Post by intense » Thu Nov 16, 2017 1:33 pm

An easylist author has been notified .. now will see what will decide ..

intense
Contributor
Contributor
Posts: 7700
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 109

Post by intense » Thu Nov 16, 2017 6:42 pm


pizza
Forum Junkie
Forum Junkie
Posts: 179
Joined: Sun Jul 09, 2017 7:09 pm
Reputation: 0

Post by pizza » Mon Apr 16, 2018 5:30 pm

In the index page... the miniatures are blurred.. and then they look black.

Code: Select all

https://www.xvideos.com/
https://i.imgur.com/JHx1glM.png

ABP - Chrome

intense
Contributor
Contributor
Posts: 7700
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 109

Post by intense » Mon Apr 16, 2018 5:39 pm


pizza
Forum Junkie
Forum Junkie
Posts: 179
Joined: Sun Jul 09, 2017 7:09 pm
Reputation: 0

Post by pizza » Mon Apr 16, 2018 6:12 pm

Thanks @intense in uBo It works well now. :)

I forgot to say that the videos do not work either, apart of the thumbnails of the home page.

yoyo94
Site Member
Site Member
Posts: 10
Joined: Fri Aug 19, 2016 5:35 pm
Reputation: 0

Post by yoyo94 » Mon Apr 16, 2018 9:08 pm

On AdBlock, the domain xvideos-cdn.com seems to be blocked

Code: Select all

https://static.xvideos-cdn.com/v-afc155966ab/v3/js/skins/min/default.header.static.js

default.header.static.js Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
(index):216 Uncaught TypeError: Cannot read property 'prepareVideo' of undefined
    at (index):216
(index):218 Uncaught TypeError: Cannot read property 'prepareVideo' of undefined
    at (index):218
default.footer.static.js Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
(index):220 Uncaught TypeError: Cannot read property 'prepareVideo' of undefined
    at (index):220
(index):222 Uncaught TypeError: Cannot read property 'prepareVideo' of undefined
    at (index):222

User avatar
fanboy
EasyList Author
EasyList Author
Posts: 9901
Joined: Wed Sep 05, 2007 8:17 pm
Reputation: 20

Post by fanboy » Mon Apr 16, 2018 10:21 pm

No issues, the videos play fine.

xvideos-tech
New Member
New Member
Posts: 6
Joined: Tue Sep 06, 2016 11:45 am
Reputation: 0

Post by xvideos-tech » Tue Apr 17, 2018 5:48 pm

fanboy wrote:
Mon Apr 16, 2018 10:21 pm
No issues, the videos play fine.
Xvideos dev here, we revert the change because of your bad rule in your files.
We always have issues with this rule when we are making some domain change :

Code: Select all

|https://$script,third-party,xmlhttprequest,domain=xvideos.com
And your users are bothered during few hours (or more) each time.

Can you remove this rule please, and replace just by the trafficfactory.biz domain (ad domain)

Example :

Code: Select all

https://rpc-php.trafficfactory.biz/json/tower-1xfooter-1/009f941c36e7a741f80027367bf8c672//xvideos////content.json?v=0.36030641847732814
Thanks

User avatar
fanboy
EasyList Author
EasyList Author
Posts: 9901
Joined: Wed Sep 05, 2007 8:17 pm
Reputation: 20

Post by fanboy » Tue Apr 17, 2018 10:44 pm

I'm will to remove the filters for xvideos.com, if xvideos stop the Adblock countering/revolving ads. Which is why it was added

xvideos-tech
New Member
New Member
Posts: 6
Joined: Tue Sep 06, 2016 11:45 am
Reputation: 0

Post by xvideos-tech » Wed Apr 18, 2018 11:00 am

We don't have any antiadblock rules now

User avatar
fanboy
EasyList Author
EasyList Author
Posts: 9901
Joined: Wed Sep 05, 2007 8:17 pm
Reputation: 20

Post by fanboy » Wed Apr 18, 2018 11:09 am

Has been temporarily removed, if we get any reports of revolving adservers or adblock countering, we'll add the filters back.

xvideos-tech
New Member
New Member
Posts: 6
Joined: Tue Sep 06, 2016 11:45 am
Reputation: 0

Post by xvideos-tech » Wed Apr 18, 2018 11:35 am

Perfect, thanks

Microbell
New Member
New Member
Posts: 3
Joined: Sun Apr 22, 2018 9:12 am
Reputation: 0

Post by Microbell » Sun Apr 22, 2018 9:39 am

Browser: Google Chrome Ver 66.0.3359.117 (Official Build) (64-bit)
Adblock Ver: 3.28.0
OS: Windows 7 64bit

Sites now have issues as of the last Easylist update which occurred a few hours ago. (4-22-2018 1:45am Est)

https://www.xvideos.com/ Blank videos (ALL) https://i.imgur.com/XqUFO11.jpg **Note** Also had missing controls but pause/enable adblock seams to have fixed it.


https://www.redtube.com/1732507 Missing Controls (All) https://i.imgur.com/qWu8KB0.jpg

This may also be occurring on other Adult sites.

If "EasyList" filter is disabled the sites operate correctly.

Microbell
New Member
New Member
Posts: 3
Joined: Sun Apr 22, 2018 9:12 am
Reputation: 0

Post by Microbell » Sun Apr 22, 2018 10:15 am

Could not find a way to edit last post so I'll add it here.

I can only find 2 errors in the Console that may or may not be the cause. (for Xvideo)

https://i.imgur.com/1dveQen.jpg

https://i.imgur.com/wKO5IK8.jpg

Six errors (for redtube)

https://i.imgur.com/GK5Y5bz.jpg

pizza
Forum Junkie
Forum Junkie
Posts: 179
Joined: Sun Jul 09, 2017 7:09 pm
Reputation: 0

Post by pizza » Mon Apr 23, 2018 2:34 pm

Could it be that the videos do not work?. you see the videos in black .. but the sound work. It just happens to me with ABP in chrome. :roll:

With ABP OFF the videos work.

With uBo (Firefox) it works well.

xvideos-tech
New Member
New Member
Posts: 6
Joined: Tue Sep 06, 2016 11:45 am
Reputation: 0

Post by xvideos-tech » Mon Apr 23, 2018 2:51 pm

Hi

I confirm that with AdBlock activated with new rule list show the video black.
I didn't succeed to understand why.

We got report from users too and we reproduce the issue on all browser / device we test with.

Post Reply