sfgate.com

Here you should report unblocked ads, trackers, social media items, annoyances or leftovers from blocked content.

Moderator: EasyList Authors

elusis
New Member
New Member
Posts: 6
Joined: Wed Dec 20, 2017 6:27 am
Reputation: 0

sfgate.com

Post by elusis » Wed Dec 20, 2017 7:13 am

Starting yesterday, every ad, autoplay video, and animated nightmare is showing up on sfgate.com - e.g.

Code: Select all

http://www.sfgate.com/bayarea/article/crowned-lemur-oakland-zoo-madagascar-12442319.php
(The first time I loaded this page, ABP said it blocked over 900 items. The second time, it said it was blocking 1 item. No idea what that's about.)

intense
Contributor
Contributor
Posts: 8507
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 139

Post by intense » Wed Dec 20, 2017 8:27 am

browser version ? ABP version ?

Check your filter lists, be sure are correctly updated.

Post some screenshot with what ads you still see on page.

elusis
New Member
New Member
Posts: 6
Joined: Wed Dec 20, 2017 6:27 am
Reputation: 0

Post by elusis » Wed Dec 20, 2017 7:27 pm


intense
Contributor
Contributor
Posts: 8507
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 139

Post by intense » Wed Dec 20, 2017 7:47 pm

I see no such ads.
Check the lists to be sure there is no failure (download with errors) on the "filter lists" tab

Only if I disable completely ABP I'm able to see those ads.

User avatar
pizza
Postaholic
Postaholic
Posts: 319
Joined: Sun Jul 09, 2017 7:09 pm
Reputation: 2

Post by pizza » Wed Dec 20, 2017 8:42 pm

I have the same problem. but this is very weird. I recorded a video of demonstration.

I also see some ads on this site. but when I give the ad with the right button, and then to inspect .. the page automatically reloads and the ads disappear! :-?

I have the same version of chrome that "elusis"

Video:

https://streamable.com/7bjxu

intense
Contributor
Contributor
Posts: 8507
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 139

Post by intense » Wed Dec 20, 2017 8:52 pm

@pizza Could you test uBo (disabling ABP) ? disable mcafee stuff.

User avatar
pizza
Postaholic
Postaholic
Posts: 319
Joined: Sun Jul 09, 2017 7:09 pm
Reputation: 2

Post by pizza » Wed Dec 20, 2017 8:56 pm

ok, the problem was the extension "Avast Online Security" :roll:

is solved for me.

thx @intense

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 14583
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 171
Location: EasyList Forum

Post by smed79 » Wed Dec 20, 2017 10:33 pm

@pizza could you test the below filter in Adblock Plus

Code: Select all

/adTools.js
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use vgy.me, imgur.com or imgbb.com to upload your screenshots

User avatar
pizza
Postaholic
Postaholic
Posts: 319
Joined: Sun Jul 09, 2017 7:09 pm
Reputation: 2

Post by pizza » Wed Dec 20, 2017 10:56 pm

:lol: thx @smed79
there are filters for everything

disabling the avast extension + ABP has removed many ads, of many web sites! :P

elusis
New Member
New Member
Posts: 6
Joined: Wed Dec 20, 2017 6:27 am
Reputation: 0

Post by elusis » Thu Dec 21, 2017 9:07 am

Interesting - I'm not running "Avast Online Security."
1Password Manager
AdBlock Plus
Black Menu for Google
Evernote Web Clipper
Flash Control
Google (Analytics blocker, Docs offline, Hangouts)
Honey
Https Everywhere
Magic Actions for YouTube
MuteTab
OneTab
Pinterest Save Button
Privacy Badger
Session Buddy
Tab Manager
Tabs Plus
The Camelizer
Video Download Helper
That's my list of enabled extensions.

elusis
New Member
New Member
Posts: 6
Joined: Wed Dec 20, 2017 6:27 am
Reputation: 0

Post by elusis » Thu Dec 21, 2017 9:11 am

intense wrote:
Wed Dec 20, 2017 7:47 pm
I see no such ads.
Check the lists to be sure there is no failure (download with errors) on the "filter lists" tab

Only if I disable completely ABP I'm able to see those ads.
Pretty sure my filter lists tab doesn't show errors:

http://i68.tinypic.com/23syhcx.png

intense
Contributor
Contributor
Posts: 8507
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 139

Post by intense » Thu Dec 21, 2017 9:18 am

1. try disabling all other extensions, test again
2. try also the filter smed79 proposed above

elusis
New Member
New Member
Posts: 6
Joined: Wed Dec 20, 2017 6:27 am
Reputation: 0

Post by elusis » Thu Dec 21, 2017 6:36 pm

I will do a test with all other extensions disabled this afternoon. How do I add the filter smed79 mentioned?

intense
Contributor
Contributor
Posts: 8507
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 139

Post by intense » Thu Dec 21, 2017 6:38 pm


elusis
New Member
New Member
Posts: 6
Joined: Wed Dec 20, 2017 6:27 am
Reputation: 0

Post by elusis » Sat Dec 23, 2017 1:09 am

OK, tested with nothing but ABP endabled. All ads are still loading, including dozens of "sponsored links" at the bottom of the page. I'll post screen shots if you want. I'll try the filter.

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 14583
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 171
Location: EasyList Forum

Post by smed79 » Sat Dec 23, 2017 1:13 am

Install "uBlock Extra".
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use vgy.me, imgur.com or imgbb.com to upload your screenshots

okiehsch
uBlock Origin Author
uBlock Origin Author
Posts: 86
Joined: Wed Oct 12, 2016 9:00 pm
Reputation: 9

Post by okiehsch » Sat Dec 23, 2017 1:31 am

@smed79 just for your information

Code: Select all

sfgate.com
uses Instart Logic.

User avatar
pizza
Postaholic
Postaholic
Posts: 319
Joined: Sun Jul 09, 2017 7:09 pm
Reputation: 2

Post by pizza » Sat Dec 23, 2017 1:45 am

mmm the ads reappears today for me with:

Code: Select all

/adTools.js
and all extensions OFF .

well.. it is an unsolved mystery

stevedb321
New Member
New Member
Posts: 9
Joined: Tue Dec 04, 2018 5:33 am
Reputation: 0

Post by stevedb321 » Tue Dec 04, 2018 5:43 am

As of this morning (Dec 3, 2018) the sfgate.com site (San Francisco Chronicle) has completely changed how they serve up scripts, images, stylesheets and xml requests. Nothing is sourced from a third party. Every script name/directory is highly encoded with what appears to be a long per-session string. Scripts originating from third parties (such as outbrain.com) appear to be routed through sfgate.com's domain so that the browser (and adblock plus) cannot identify them as third party.

The page still loads with my adlblock plus running but it is very slow and wonky - ads are displayed and popping up, as are sponsored content (outbrain) that were previously blocked as well as a nasty pop up video.

Here's an example of what their scripts look like now:

Code: Select all

https://c-8oqtgrjgwu46x24udx2eueqtgectftgugctejx2eeqo.g00.sfgate.com/g00/3_c-8yyy.uhicvg.eqo_/c-8OQTGRJGWU46x24jvvrux3ax.....k32e.octmx3dkocig_$/$
Has anyone noted this yet?

Steve DB

intense
Contributor
Contributor
Posts: 8507
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 139

Post by intense » Tue Dec 04, 2018 10:02 am

Install ublock extra
https://chrome.google.com/webstore/deta ... ffkjpaplco

(is working together your ABP - dedicated to a class of very nasty ads)

stevedb321
New Member
New Member
Posts: 9
Joined: Tue Dec 04, 2018 5:33 am
Reputation: 0

Post by stevedb321 » Tue Dec 04, 2018 5:24 pm

Will give it a try and report back.

stevedb321
New Member
New Member
Posts: 9
Joined: Tue Dec 04, 2018 5:33 am
Reputation: 0

Post by stevedb321 » Fri Dec 07, 2018 6:15 pm

OK, this morning I was surprised to see that SFGate.com is back to "normal" I did not have time to change any settings on my adblocker at all. So I have to assume that a change was made either by EasyList or by one of the other filters I have in use: ABP and EasyPrivacy.

Upon examining the ABP filters that are triggered on sfgate.com, I see a new SNIPPET blocked from the list ABP (not from EasyList)

Code: Select all

sfgate.com#$#abort-on-property-read I10C
This seems to deal with pretty much all ads and other bad behavior. The type of item blocked is called SNIPPET and I am not sure what this is and how it works. But very clever, nonetheless.

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 14583
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 171
Location: EasyList Forum

Post by smed79 » Sat Dec 08, 2018 1:11 am

stevedb321 wrote:
Fri Dec 07, 2018 6:15 pm
I am not sure what this is and how it works.
https://adblockplus.org/releases/adbloc ... a-released
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use vgy.me, imgur.com or imgbb.com to upload your screenshots

stevedb321
New Member
New Member
Posts: 9
Joined: Tue Dec 04, 2018 5:33 am
Reputation: 0

Post by stevedb321 » Tue Dec 25, 2018 6:27 am

Update Dec 24, 2018- The new Easy List rule which is a SNIPPET worked on sfgate.com for a couple of weeks (starting on around Dec 7). However in mid December I experienced the same old problem again -- even through the AdblockPlus showed that the SNIPPET was still being blocked.

Code: Select all

https://www.sfgate.com/g00/?i10c.encReferrer=&i10c.ua=2&i10c.dv=6
So something changed yet again around the middle of December.

The funny thing is that my wife's Mac Air running Mozilla with the same settings as I have for ABP still works. I've tried to see if there is a difference somewhere in the settings but nothing obvious turns up.

I am running Firefox 64.0 (64 bit) with ABP 3.4.2 and the following filters: Easy Privacy, Fan Boys Social Blocking, ABP filters, Easy List.
I have multiple machines - Windows 10, Windows 7 and MacOS (the latest OS update I believe) get the same behavior on all three.

Any ideas? (I did find and block the following:

Code: Select all

||sdad.guru^ 

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 14583
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 171
Location: EasyList Forum

Post by smed79 » Tue Dec 25, 2018 3:01 pm

test the below filter

Code: Select all

sfgate.com#$#abort-on-property-read I11C
(https://github.com/abp-filters/abp-filt ... /issues/36)
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use vgy.me, imgur.com or imgbb.com to upload your screenshots

stevedb321
New Member
New Member
Posts: 9
Joined: Tue Dec 04, 2018 5:33 am
Reputation: 0

Post by stevedb321 » Tue Dec 25, 2018 10:14 pm

@smed79 Just tried it. No change. Still getting all the ads, sponsored stuff, etc ...

intense
Contributor
Contributor
Posts: 8507
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 139

Post by intense » Tue Dec 25, 2018 11:02 pm

try (I11C is working for me, but try it .. could be you are served a different page)

Code: Select all

sfgate.com#$#abort-on-property-read I10C

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 14583
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 171
Location: EasyList Forum

Post by smed79 » Wed Dec 26, 2018 1:04 am

stevedb321 wrote:Still getting all the ads, ...
As said above ~ " could be you are served a different page "

Paste the HTML source code of a home page at ghostbin.com then post the link here.
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use vgy.me, imgur.com or imgbb.com to upload your screenshots

stevedb321
New Member
New Member
Posts: 9
Joined: Tue Dec 04, 2018 5:33 am
Reputation: 0

Post by stevedb321 » Thu Dec 27, 2018 4:37 pm

suddenly sfgate .com is working correctly on Dec 27th. As I did not change anything, I assume that the Easy List got updated. Thanks!

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 14583
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 171
Location: EasyList Forum

Post by smed79 » Thu Dec 27, 2018 5:45 pm

stevedb321 wrote:
Thu Dec 27, 2018 4:37 pm
I assume that the Easy List got updated.
Fixed in "ABP filters" https://github.com/abp-filters/abp-filt ... 0fe02759e4
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »
•••► Use vgy.me, imgur.com or imgbb.com to upload your screenshots

Post Reply