If you've been sent to this forum because one of the sites you're browsing has no images please see this.
If you're not sure if the site you're browsing is affected by this please check the link above.

Notifications options page in UCP appears to be broken

General forum information, announcements, news, questions and suggestions.

Moderator: EasyList authors

Locked
brossow
Site Member
Site Member
Posts: 10
Joined: Thu Jan 12, 2017 6:40 pm
Reputation: 0

Notifications options page in UCP appears to be broken

Post by brossow » Fri Jan 13, 2017 2:20 pm

I'm a new user and in trying to configure my options and notifications for the forum, I noticed that I could not access the notification options page in the User Control Panel (UCP > Board preferences > Edit notification options -- ucp.php?i=ucp_notifications&mode=notification_options ).

Instead, I get the following PHP error:

Code: Select all

Catchable fatal error: Argument 1 passed to phpbb\notification\type\base::__construct() must implement interface phpbb\db\driver\driver_interface, instance of phpbb\user_loader given, called in /home/lanik/forums/cache/production/container_4335734bbdd20f586549a504dff5f80c.php on line 3324 and defined in /home/lanik/forums/phpbb/notification/type/base.php on line 87

Did a quick search in this forum and didn't find mention of it, so thought I'd note it here in case it wasn't a known issue.

User avatar
Lanik
Site Owner
Site Owner
Posts: 1188
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 10
Location: West Coast, USA

Post by Lanik » Fri Jan 13, 2017 8:59 pm

Thanks for the heads up, it should be resolved now. I had to fix your link since that wasn't the right link I assume. It had an extra character at the end. If that's not the intended result let me know.
"If it ain't broke don't fix it."

brossow
Site Member
Site Member
Posts: 10
Joined: Thu Jan 12, 2017 6:40 pm
Reputation: 0

Post by brossow » Fri Jan 13, 2017 9:33 pm

It's working now. Thanks!

User avatar
Lanik
Site Owner
Site Owner
Posts: 1188
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 10
Location: West Coast, USA

Post by Lanik » Fri Jan 13, 2017 11:15 pm

Nope still broken I'm looking at it though.
"If it ain't broke don't fix it."

User avatar
Lanik
Site Owner
Site Owner
Posts: 1188
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 10
Location: West Coast, USA

Post by Lanik » Sat Jan 14, 2017 1:25 am

This is due to the upgrade to PHPBB 3.2: viewtopic.php?f=9&t=35070
"If it ain't broke don't fix it."

Locked

Who is online

Users browsing this forum: No registered users and 2 guests