Captcha Missing when posting anonymously

General forum information, announcements, news, questions and suggestions.

Moderator: EasyList authors

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 11878
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 96
Location: EasyList Forum

Re: Captcha Missing when posting anonymously

Post by smed79 » Tue Dec 20, 2016 5:20 pm

Same issue after solving google recapcha http://i.imgur.com/kK12tJN.png & http://i.imgur.com/Ea3n7SD.png
Fatal error: Cannot redeclare user_get_id_name() (previously declared in /home/lanik/forums/includes/functions_user.php:30) in /home/lanik/forums/includes/functions_user.php on line 85
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »

User avatar
Lanik
Site Owner
Site Owner
Posts: 1379
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 22
Location: /dev/null

Post by Lanik » Tue Dec 20, 2016 6:28 pm

I just tested from my cell phone and so far it works great. I tried to post a new topic and reply to an existing topic.
"If it ain't broke don't fix it."

phpl
New Member
New Member
Posts: 1
Joined: Tue Jan 10, 2017 11:45 pm
Reputation: 0

Post by phpl » Tue Jan 10, 2017 11:49 pm

This error is still there after solving the captcha:
Fatal error: Cannot redeclare user_get_id_name() (previously declared in /home/lanik/forums/includes/functions_user.php:30) in /home/lanik/forums/includes/functions_user.php on line 85
Couldn't post anonymous, couldn't use a trashmail for registering, guess you don't really want help with the filters now making it hard to contribute ...

Well as long as it works from one single mobile device, everything is alright?

User avatar
Lanik
Site Owner
Site Owner
Posts: 1379
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 22
Location: /dev/null

Post by Lanik » Wed Jan 11, 2017 12:20 am

phpl wrote:Couldn't post anonymous, couldn't use a trashmail for registering, guess you don't really want help with the filters now making it hard to contribute ...
That's what I have to do to fight spam. Unless you want this forum to turn into spam central. I don't see anyone getting any help with anything around here besides viagra and whatever other nonsense people are peddling these days.

I don't care much about anon posters if one doesn't care to register they don't care much to contribute either beyond the initial question.
"If it ain't broke don't fix it."

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 11878
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 96
Location: EasyList Forum

Post by smed79 » Fri Jan 27, 2017 3:35 pm

@Lanik Just FYI, http://i.imgur.com/hYdJ7Gq.png ...after solving the recaptcha.

(from : viewtopic.php?p=112450#p112450)
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »

User avatar
Lanik
Site Owner
Site Owner
Posts: 1379
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 22
Location: /dev/null

Post by Lanik » Fri Jan 27, 2017 7:04 pm

Okay please try that again and see what happens.
"If it ain't broke don't fix it."

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 11878
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 96
Location: EasyList Forum

Post by smed79 » Fri Jan 27, 2017 8:11 pm

•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »

User avatar
Lanik
Site Owner
Site Owner
Posts: 1379
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 22
Location: /dev/null

Post by Lanik » Fri Jan 27, 2017 9:07 pm

That's not an extension any longer that's what's built into PHPBB now. I cleared out the cache in the forum and CloudFlare so I'm at a loss right now.
"If it ain't broke don't fix it."

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 11878
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 96
Location: EasyList Forum

Post by smed79 » Sat Jan 28, 2017 12:21 am

... topic pagination is missed now :-p
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »

User avatar
Lanik
Site Owner
Site Owner
Posts: 1379
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 22
Location: /dev/null

Post by Lanik » Sat Jan 28, 2017 11:07 pm

smed79 wrote:
Sat Jan 28, 2017 12:21 am
... topic pagination is missed now :-p
Can you please elaborate? I'm not seeing anything when I page through topics right now.
"If it ain't broke don't fix it."

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 11878
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 96
Location: EasyList Forum

Post by smed79 » Sun Jan 29, 2017 1:02 am

Sorry, it's about these topics which has more than xx posts per page to show multiple pages:

- http://i.imgur.com/kDk1vaw.png
- http://i.imgur.com/8GD3dja.png

Yesterday there was no pagination and all messages have been displayed on the same page but fixed right now.

PS: http://i.imgur.com/8bllyA8.png i think the default should be 50 topics per page & 15 posts per page.

Thank you for your time.
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »

User avatar
Lanik
Site Owner
Site Owner
Posts: 1379
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 22
Location: /dev/null

Post by Lanik » Sun Jan 29, 2017 1:17 am

I custom set mine to 50 posts per page. The board setting isn't enforced though so I'll set it to 30 topics per page and 50 posts per page.
"If it ain't broke don't fix it."

adblock321
New Member
New Member
Posts: 2
Joined: Sun Mar 26, 2017 3:31 pm
Reputation: 0

Post by adblock321 » Sun Mar 26, 2017 3:34 pm

There's a field for a captcha, however no captcha is shown when posting without loggin in.
When trying to submit an answer, the following error is shown:
Fatal error: Cannot redeclare user_get_id_name() (previously declared in /home/lanik/forums/includes/functions_user.php:30) in /home/lanik/forums/includes/functions_user.php on line 85

Locked