thepiratebay.org

This is where you should report issues arising from the subscription filters.

Moderator: EasyList authors

Post Reply
Dypsis
New Member
New Member
Posts: 3
Joined: Wed Aug 23, 2017 5:21 am
Reputation: 0

thepiratebay.org

Post by Dypsis » Wed Aug 23, 2017 6:03 am

There is something in EasyList that is blocking magnet links on thepiratebay.org when using Vivaldi.
If I untick Easylist, the magnet links work.

intense
Contributor
Contributor
Posts: 6696
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 74

Post by intense » Wed Aug 23, 2017 9:18 am

adblocker (version) ?
enabled filter lists ?

disable all other blocking extensions (including web shields in your antivirus), test again.

Dypsis
New Member
New Member
Posts: 3
Joined: Wed Aug 23, 2017 5:21 am
Reputation: 0

Post by Dypsis » Wed Aug 23, 2017 8:53 pm

Adblock Plus is the only blocking extension I have.

Adblock Warning Removal List
EasyList
Fanboy's Annoyance List

If I disable Adblock Warning Removal List and Fanboy's Annoyance List, the problem still exists.
It's only fixed when I disable EasyList.

intense
Contributor
Contributor
Posts: 6696
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 74

Post by intense » Wed Aug 23, 2017 9:29 pm

Still no issue for me, tested also vivaldi + ABP.

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 11701
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 92
Location: EasyList Forum

Post by smed79 » Thu Aug 24, 2017 1:00 am

If you can reproduce your issue in firefox + adblock plus, submit an issue report and past here the link.
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »

Dypsis
New Member
New Member
Posts: 3
Joined: Wed Aug 23, 2017 5:21 am
Reputation: 0

Post by Dypsis » Thu Aug 24, 2017 1:34 am

But, that's the odd thing about it.
I can't reproduce it in Firefox.

I just uninstalled Vivaldi completely and removed the profile, and started from scratch. I installed Vivaldi Snapshot v1.12.936.3. I had a thepiratebay.org page open checking a magnet link. It was working fine right up to the point that I installed ABP with EasyList. No other extensions. Just ABP with EasyList. If I disable EasyList, the magnet link works.

Update: What I have found since last posting is that there is actually a very small part of the "GET THIS TORRENT" magnet link working. The only live part of it is the "ENT" part of the link.

This pic is with EasyList enabled and showing the magnet link dead.
Image

This pic is with EasyList still enabled showing the small portion of the magnet link live at the "ENT" part of it.
Image

This is with EasyList disabled and the magnet link fully working.
Image

EmptyJay
New Member
New Member
Posts: 1
Joined: Thu Sep 14, 2017 3:32 pm
Reputation: 0

Post by EmptyJay » Thu Sep 14, 2017 3:34 pm

I found the rule that's causing the magnet links to be removed.

Code: Select all

||thepiratebay.org^$script,domain=thepiratebay.org

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 11701
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 92
Location: EasyList Forum

Post by smed79 » Mon Sep 18, 2017 4:30 pm

EmptyJay wrote:
Thu Sep 14, 2017 3:34 pm
I found the rule that's causing the magnet links to be removed.
No issue http://i.imgur.com/j2zsGsM.png :roll:
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »

Sv18
Site Member
Site Member
Posts: 18
Joined: Fri Sep 01, 2017 9:09 pm
Reputation: 0

Post by Sv18 » Sat Nov 11, 2017 4:46 pm

I cannot click "Get this torrent" while ABP is on. Nothing happens when I hover over it.

intense
Contributor
Contributor
Posts: 6696
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 74

Post by intense » Sat Nov 11, 2017 5:03 pm

- provide a specific page where "get this torrent" appears
- adblocker ?
- filter lists ?
- browser version ?

Sv18
Site Member
Site Member
Posts: 18
Joined: Fri Sep 01, 2017 9:09 pm
Reputation: 0

Post by Sv18 » Sat Nov 11, 2017 5:31 pm

It happens on every torrent page.
I have the latest version of Adblock Plus.
I have the Anti Adblock Killer list, Adblock Warning Removal list, EasyList and EasyPrivacy lists active.

I found I must deactivate EasyList so I can click the "Get this torrent" link.
The other lists have nothing to do with the problem.
EDIT: I'm using Firefox 56.0.2 (64-bit)

Sv18
Site Member
Site Member
Posts: 18
Joined: Fri Sep 01, 2017 9:09 pm
Reputation: 0

Post by Sv18 » Sat Nov 11, 2017 5:58 pm

Example:

Code: Select all

https://thepiratebay.org/torrent/14184502/Dark_Souls_Prepare_to_Die_Edition_repack_Mr_DJ

intense
Contributor
Contributor
Posts: 6696
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 74

Post by intense » Sat Nov 11, 2017 5:59 pm

try

Code: Select all

@@||thepiratebay.org/static/*/ad-scroll.js

Sv18
Site Member
Site Member
Posts: 18
Joined: Fri Sep 01, 2017 9:09 pm
Reputation: 0

Post by Sv18 » Sat Nov 11, 2017 6:05 pm

It works now.

Post Reply