NSFW gelbooru.com

This is where you should report issues arising from the subscription filters.

Moderator: EasyList authors

STR8_AN94BALLER
Site Member
Site Member
Posts: 27
Joined: Mon Apr 24, 2017 11:25 am
Reputation: 0

Re: NSFW gelbooru.com

Post by STR8_AN94BALLER » Tue Aug 15, 2017 2:02 pm

smed79 wrote:
Mon Aug 07, 2017 10:06 am
Still not able to reproduce the issue.
Test in chrome or firefox portable https://portableapps.com/apps/internet
FF portable here, tried multiple times don't work either. Ublock or abp [one at a time].

intense
Contributor
Contributor
Posts: 6374
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 65

Post by intense » Tue Aug 15, 2017 2:06 pm

Disable all other addons, test again.
If your antivirus has the web shields ON, switch OFF that setting and test again.

STR8_AN94BALLER
Site Member
Site Member
Posts: 27
Joined: Mon Apr 24, 2017 11:25 am
Reputation: 0

Post by STR8_AN94BALLER » Tue Aug 15, 2017 3:14 pm

intense wrote:
Tue Aug 15, 2017 2:06 pm
Disable all other addons, test again.
If your antivirus has the web shields ON, switch OFF that setting and test again.
Apparently the problem was with fanboy enhanced tracking list.

STR8_AN94BALLER
Site Member
Site Member
Posts: 27
Joined: Mon Apr 24, 2017 11:25 am
Reputation: 0

Post by STR8_AN94BALLER » Sat Aug 26, 2017 9:42 pm

New update on gelbooru breaks image viewing again. Using latest filters (fanboy enhance tracking disabled) and the two custom filters

Code: Select all

@@||maxcdn.bootstrapcdn.com/bootstrap/$script,domain=gelbooru.com
@@||ajax.googleapis.com/ajax/libs/jquery/$script,domain=gelbooru.com
Edit: Nvm seems to be a site issue with some of the images.

milkguy288
New Member
New Member
Posts: 4
Joined: Wed Jul 19, 2017 3:00 pm
Reputation: 0

Post by milkguy288 » Fri Sep 01, 2017 3:48 pm

after the new firefox broke all addons i have installed i checked again with the new compatible Ublock+
did all suggested tests issue with images and thumbnails persisted.
added these filters as previously discussed:

Code: Select all

@@||gelbooru.com/ads.js
gelbooru.com##A[href*="/track/"]
gelbooru.com#@#span[class]:last-child > a img[src]
@@||gelbooru.com/thumbnails/$image
@@||maxcdn.bootstrapcdn.com/bootstrap/$script,domain=gelbooru.com
@@||ajax.googleapis.com/ajax/libs/jquery/$script,domain=gelbooru.com
this solved thumbnails not appearing but full images still did not appear.
did the following test:
1- with Fanboy’s Enhanced Tracking List <PLUS> Fanboy’s Social Blocking List <PLUS> Fanboy+Easylist-Merged Ultimate List <ENABLED> opened the first row of thumbnails. NO image Loaded
2- with Filters DISABLED opened the first row of thumbnails. all images Loaded
3- with Fanboy+Easylist-Merged Ultimate List <ENABLED> Alone or in any combination with the others. NO Image Loaded
4- with Fanboy’s Social Blocking List <ENABLED> Alone All images loaded
5- with Fanboy’s Enhanced Tracking List <ENABLED> Alone SOME images loaded.

it seems to me that the issue is in some part of the shared code between Fanboy+Easylist-Merged Ultimate List and Fanboy’s Enhanced Tracking List.

xk1
New Member
New Member
Posts: 1
Joined: Tue Sep 05, 2017 3:21 pm
Reputation: 0

Post by xk1 » Tue Sep 05, 2017 3:36 pm

Following modifications worked for me on the latest site changes:
Disable this rule:

Code: Select all

gelbooru.com##span[class]:last-child > a img[src]
Add these rules:

Code: Select all

gelbooru.com##div#paginater>span>a>img
gelbooru.com##span#nup
gelbooru.com##span#tup

BigMac
New Member
New Member
Posts: 2
Joined: Mon Oct 02, 2017 4:50 am
Reputation: 0

Post by BigMac » Mon Oct 02, 2017 4:54 am

At least image thumbnails are broken because of this script:

Code: Select all

|https://$script,xmlhttprequest,domain=gelbooru.com

Isn't that too broad blocking? Same kind of block is used for few other sites also.

Rohrich
Site Member
Site Member
Posts: 37
Joined: Tue Dec 27, 2016 8:16 pm
Reputation: 0

Post by Rohrich » Mon Oct 02, 2017 4:23 pm

Appearently it's not even adblocks fault, they completely broke the goddam site.

BigMac
New Member
New Member
Posts: 2
Joined: Mon Oct 02, 2017 4:50 am
Reputation: 0

Post by BigMac » Mon Oct 02, 2017 7:42 pm

Rohrich wrote:
Mon Oct 02, 2017 4:23 pm
Appearently it's not even adblocks fault, they completely broke the goddam site.
They had a problem that the site was broken with older browsers also but they fixed it, but from my understanding this rule blocks all scripts on there causing features like the thumbnails to break. (The reason it broke now is because they started using javascript to load the thumbnails.)
Disabling that rule causes the site to work properly so it should be removed from the list, and it might be a good idea to check if other similar broad blocks are unnecessary.

intense
Contributor
Contributor
Posts: 6374
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 65

Post by intense » Mon Oct 02, 2017 7:53 pm

if you use uBo just update your lists.

Otherwise add

Code: Select all

@@||gelbooru.com^$script
gelbooru.com#@#span[class]:last-child > a img[src]
@@||googleapis.com/*/jquery.min.js$script,domain=gelbooru.com

Aurani
New Member
New Member
Posts: 2
Joined: Fri Oct 06, 2017 5:04 am
Reputation: 0

Post by Aurani » Fri Oct 06, 2017 5:20 am

Anyone have a fix for the multiple banner ads that appear at the bottom of the page? I tried several of the user filters posted in here but nothing seemed to work.
Doesn't help that I just got done updating to Waterfox 55.2.0 which screwed up everything, purging and installing the new AAK for uBO and the script/lists for Tampermonkey and gelbooru's full of those ads again. :/

intense
Contributor
Contributor
Posts: 6374
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 65

Post by intense » Fri Oct 06, 2017 6:36 am

for ubo add

Code: Select all

||gelbooru.com/*.php$script,important

Aurani
New Member
New Member
Posts: 2
Joined: Fri Oct 06, 2017 5:04 am
Reputation: 0

Post by Aurani » Fri Oct 06, 2017 8:04 am

That only removes the banner images, the banner box itself remains on the page and can still be clicked on.

intense
Contributor
Contributor
Posts: 6374
Joined: Wed Mar 27, 2013 9:56 am
Reputation: 65

Post by intense » Fri Oct 06, 2017 8:26 am

update your "ublock filters"

Rohrich
Site Member
Site Member
Posts: 37
Joined: Tue Dec 27, 2016 8:16 pm
Reputation: 0

Post by Rohrich » Sat Oct 07, 2017 3:01 pm

I have noticed something odd:
With adblock the main page has tons of empty space at the bottom, without it looks normal.
No pictures are missing, I've counted them.
Where's the empty space coming from?
With main page I mean:

Code: Select all

https://gelbooru.com/index.php?page=post&s=list

Sv18
Site Member
Site Member
Posts: 10
Joined: Fri Sep 01, 2017 9:09 pm
Reputation: 0

Post by Sv18 » Sat Oct 14, 2017 4:28 am

Sorry for omitting the NSFW warning earlier, won't make the same mistake.

Images do not load and instead display the text "Download" + an ad still shows at the top.
I have the following custom filters in effect:

Code: Select all

gelbooru.com##div#paginater>span>a>img
gelbooru.com##span#nup
gelbooru.com##span#tup
All advertising trackers are blocked by Ghostery but I find it doesn't have anything to do with the issue.
Image: https://i.imgur.com/jT9uV0I.png
Moderator Message:
Merged -: rules#forumsearch
- smed79

Post Reply