If you've been sent to this forum because one of the sites you're browsing has no images please see this.
If you're not sure if the site you're browsing is affected by this please check the link above.

youtube.com

Here you should report unblocked ads, trackers, social media items, annoyances or leftovers from blocked content.

Moderator: EasyList authors

User avatar
Lanik
Site Owner
Site Owner
Posts: 1190
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 10
Location: West Coast, USA

Re: youtube.com

Post by Lanik » Tue Feb 28, 2017 8:18 pm

aantony wrote:
Tue Feb 28, 2017 8:09 pm

Code: Select all

youtube.com##https://www.youtube.com/get_video_info*
That's not a valid filter as you're mixing your CSS and network selectors: https://adblockplus.org/filters
"If it ain't broke don't fix it."

User avatar
smed79
Liste AR Author
Liste AR Author
Posts: 9614
Joined: Sun Jan 17, 2010 4:00 am
Reputation: 33
Location: EasyList Forum

Post by smed79 » Tue Feb 28, 2017 8:35 pm

youtube.com/get_video_info? I think has nothing to do with the pre-roll ads.

Is to send a request with the parameters contain information such as the video ID, the player width/height, and what host is requesting the video.

Test here https://www.h3xed.com/blogmedia/youtube-info.php

e.g https://vgy.me/1almkH.png
•► Before posting, to find your answer fast, read Forum « RULES » and use « Search »
••► Don't post clickable links » use inline text bbcode notation « [ C ] » or « [ code ] »

BenFenner
New Member
New Member
Posts: 4
Joined: Wed Mar 01, 2017 1:41 pm
Reputation: 0

Post by BenFenner » Wed Mar 01, 2017 1:51 pm

Maybe this is the wrong thread and this should be in a new thread. Let me know, sorry I'm new here.

As of yesterday, YouTube is showing 30-second video ads to my browsers that have AdBlocking and EasyList subscriptions.
This hasn't happened to me in many, many years so I was a bit shocked.
Here is an example video (youtube.com/watch?v=mB2_7pInWPM) that shows an ad for Old Navy.
This has been confirmed on a few machines I'll list below. No new updates to the OS, Browser, or Adblocker happened.
OS: Windows 7 (64-bit)
Browser: Pale Moon 27.1.1
Adblocker: Adblock Latitude 4.0.1
Adblocker subscriptions: EasyList (up to date)
OS: Arch Linux (64-bit)
Browser: Pale Moon 27.1.1
Adblocker: Adblock Latitude 4.0.1
Adblocker subscriptions: EasyList (up to date)
OS: Arch Linux (64-bit)
Browser: Pale Moon 27.1.1
Adblocker: ABPrime 1.0.0
Adblocker subscriptions: EasyList (up to date)
Also, if anyone could let me know where to report problems with the forum that would be nice.
Posting as a guest is broken. So I've signed up to post this.

aantony
New Member
New Member
Posts: 3
Joined: Fri Feb 17, 2017 10:08 pm
Reputation: 0

Post by aantony » Wed Mar 01, 2017 5:45 pm

Lanik wrote:
Tue Feb 28, 2017 8:18 pm
aantony wrote:
Tue Feb 28, 2017 8:09 pm

Code: Select all

youtube.com##https://www.youtube.com/get_video_info*
That's not a valid filter as you're mixing your CSS and network selectors: https://adblockplus.org/filters
Yes, you are right that something must be wrong with my *scoped* rule. I was trying to follow the "Limiting rules to certain domains" section of the adblock filters instructions. I did some hasty testing mostly focussing on the embedded player, and thought it was working when I posted. I did see more preroll ads afterwards. I later tried tried various other experiments, but couldn't seem to get it to work reliably with "scoping". For me, the *unscoped* rule still works. As I reported earlier, the embedded player is affected by this rule. I haven't found a way to resolve that yet.
smed79 wrote:
Tue Feb 28, 2017 8:35 pm
youtube.com/get_video_info? I think has nothing to do with the pre-roll ads.
I don't know much about this, but my tests seem pretty consistent, that blocking that request is preventing the preroll from playing. The yellow ad markers still appear, and there is a brief moment before the video starts where the player area is black and the sponsor's urls appears as a tiny annotation, but instead of playing the sponsor video, it goes to the content.

Here is one such request. I don't know if there is anything meaningful here.

Code: Select all

https://www.youtube.com/get_video_info?html5=1&video_id=mTrr9ohR-Mo&cpn=vR6sAtyTORpAuGLV&eurl&el=adunit&hl=en_US&agcid=160772447493&aqi=gwa3WPeiCsKEMKbCh5AC&sts=17217&lact=1374&c=WEB&cver=1.20170222&cplayer=UNIPLAYER&cbr=Chrome&cbrver=56.0.2924.87&cos=Windows&cosver=10.0&adformat=15_2_1&iv_load_policy=1&autoplay=1&width=1280&height=720&content_v=nhEn-qW9HEc&authuser=0&ei=gga3WPOkNov38gTt3KHwBA 
The words "adunit" and "adformat" appear in the request. (Hopefully I'm not leaking any private data in that link)

BenFenner
New Member
New Member
Posts: 4
Joined: Wed Mar 01, 2017 1:41 pm
Reputation: 0

Post by BenFenner » Sat Mar 04, 2017 12:52 am

I can confim the 30-second preroll ads play only when I'm logged in. If I'm logged out of YouTube, they don't run. Looks like some new ad technique
YouTube is testing on select users.

gotitbro
Postaholic
Postaholic
Posts: 575
Joined: Sat Jul 09, 2016 8:33 pm
Reputation: 1

Post by gotitbro » Sat Mar 04, 2017 1:39 am

BenFenner wrote:
Sat Mar 04, 2017 12:52 am
I can confim the 30-second preroll ads play only when I'm logged in. If I'm logged out of YouTube, they don't run. Looks like some new ad technique
YouTube is testing on select users.
Why don't you submit an Adblock Plus report: https://adblockplus.org/en/getting_started#problems (as @smed79 has pointed out earlier in this thread).
Use Firefox portable http://portableapps.com/apps/internet/firefox_portable with Adblock Plus.

BenFenner
New Member
New Member
Posts: 4
Joined: Wed Mar 01, 2017 1:41 pm
Reputation: 0

Post by BenFenner » Sat Mar 11, 2017 1:23 am

gotitbro wrote:
Sat Mar 04, 2017 1:39 am
Why don't you submit an Adblock Plus report: https://adblockplus.org/en/getting_started#problems (as @smed79 has pointed out earlier in this thread).
I don't use Adblock Plus on any of my machines, and the issue seems to be with Easy List. What would reporting it to Adblock Plus accomplish? Not trying to be snarky. If that's the right place for this report, I'm all ears.
gotitbro wrote:
Sat Mar 04, 2017 1:39 am
Use Firefox portable http://portableapps.com/apps/internet/firefox_portable with Adblock Plus.
What for exactly? I much prefer Pale Moon and Pale Moon Portable if the need arises.

User avatar
Lanik
Site Owner
Site Owner
Posts: 1190
Joined: Thu Feb 15, 2007 7:44 am
Reputation: 10
Location: West Coast, USA

Post by Lanik » Sat Mar 11, 2017 2:09 am

Valid question if you ask me.

By submitting AdBlock Plus report we can see what your browser sees as well as any AdBlock Plus settings, screenshots etc you may have.

AdBlock Plus reporter doesn't work on Pale Moon AFAIK, so if you don't want to install FireFox you can use portable version.

Edit: Clarification
"If it ain't broke don't fix it."

gotitbro
Postaholic
Postaholic
Posts: 575
Joined: Sat Jul 09, 2016 8:33 pm
Reputation: 1

Post by gotitbro » Sat Mar 11, 2017 7:03 am

BenFenner wrote:
Sat Mar 11, 2017 1:23 am
I don't use Adblock Plus on any of my machines, and the issue seems to be with Easy List. What would reporting it to Adblock Plus accomplish? Not trying to be snarky. If that's the right place for this report, I'm all ears.
Since, none of the list maintainers and the moderators here aren't seeing the ad they can't dissect what exactly is causing the ad to load for you. And the only way they can help is by seeing the log, to see which connections are being allowed and which are blocked (maybe the ads are loaded from a new server or they are being let through by another program or an exception filter) and they can tell you what might be causing the ads to load.
And one of the best tools specifically designed to record the logs and provide info on which filters are being used and the screenshot of the of the ad is the AdBlock Plus report tool (this tool does not send any personally identifiable information).

You can then paste the report URL here and the list maintainers can help you much much more easily then.
BenFenner wrote:
Sat Mar 11, 2017 1:23 am
What for exactly? I much prefer Pale Moon and Pale Moon Portable if the need arises.
A portable Firefox version can be removed easily after installation and will provide a clean AdBlock Plus report without any of Pale Moons additional features interfering.

BenFenner
New Member
New Member
Posts: 4
Joined: Wed Mar 01, 2017 1:41 pm
Reputation: 0

Post by BenFenner » Sun Mar 12, 2017 3:51 pm

Thanks for the kind answers to what I realize now were complete newb questions. I will get an AdBLock Plus report in today once I've had some breakfast. I'll do one report without being logged in (no ads) and another while being logged in (ads present).

itsallinyourhead
Site Member
Site Member
Posts: 11
Joined: Wed Jan 28, 2015 2:50 am
Reputation: 0

Post by itsallinyourhead » Sat Mar 18, 2017 3:53 pm

Could you please add

Code: Select all

youtube.com###player-ads
to https://easylist-downloads.adblockplus.org/easylist.txt ?

'player-ads' is the id of an ad iframe above the 'Up next' video in youtube's new design.

That iframe is already hidden cause of its source 'googleads.g.doubleclick.net'. But it is visible for a moment during page load and moves the video suggestions when it gets hidden (by a content script, I guess).
An well written adblocker would hide that iframe from the beginning with the filter above and make page load more comfortable.
Moderator Message:
Merged your topic: rules#forumsearch
- smed79

mynameisnotspam
Senior Member
Senior Member
Posts: 63
Joined: Fri Jun 27, 2014 12:46 am
Reputation: 0
Location: Chilliwack, BC Canada

Post by mynameisnotspam » Sat Mar 18, 2017 10:58 pm

I had a issue with my personal filters that was found to be allowing ads on youtube.
I think I had too many allow and block rules scattered everywhere that was causing it.
I since put all my allow rules beginning with @@|| at the top of the list then put a space and then all my blocking rules under this line:

Code: Select all

! [Ad Blocking Rules]/blocking
||example.com
||ytimg.com/yts/jsbin/*/watch_autoplayrenderer.js$important

This seems to have fixed it.
Sorry for any confusion

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests